2
Vote

System.Exception: Could not connect to server

description

Hi!
 
I am getting an error when I try to install the reports. Im not that familar with the sql reporting services so it could be a very basic error.
Or could it be that I am on a 64-bit machine?
 
Anyway, what I get is pasted below when I try to run DeployReports.cmd.
 
I have tried to change the loclahost to our servername but still same error. IIS is up and running. Any hints on troubleshooting?
 
 

This script will deploy DMVstats reports to the
SQL Server Reporting Services instance at
     http://localhost/reportserver
 
Press any key to continue or CTRL-C to abort ....

Beginning report deployment...
System.Exception: Could not connect to server: http://localhost/reportserver/ReportService2005.asmx ---> System.Net.WebE
xception: The request failed with HTTP status 404: Not Found.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response,
Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.SqlServer.ReportingServices2005.ReportingService2005.ListSecureMethods()
at Microsoft.ReportingServices.ScriptHost.Management2005Endpoint.PingService(String url, String userName, String pass
word, String domain, Int32 timeout)
at Microsoft.ReportingServices.ScriptHost.ScriptHost.DetermineServerUrlSecurity()
--- End of inner exception stack trace ---
at Microsoft.ReportingServices.ScriptHost.ScriptHost.DetermineServerUrlSecurity()
at Microsoft.ReportingServices.ScriptHost.ScriptHost.InstanceMain()
at Microsoft.ReportingServices.BaseCmdLine.CommandLineMain(String[] args, BaseCmdLine instance)
== An error occurred. See P:\Microsoft\SQLServer\dmvstats 1.01\DeployReports.log for details
Press any key to continue . . .
 
The DeployReports.log is empty.
 
Thanks
Ola

comments

Scoop wrote May 13, 2008 at 7:09 PM

What was the resolution for this issue you were having if you do not mind sharing??

We are trying to Deploy the deployreports.cmd also but to sharepoint 3.0 report server URL and are receiving the same error.

Help anyone??/

wrote May 14, 2008 at 2:14 PM

wrote Feb 14, 2013 at 2:29 AM